Cisco: DHCP

Neste post vou demonstrar a configuração do DHCP em dispositivos Cisco.

Topologia utilizada para demonstrar as configurações:

cisco_dhcp01

Primeiramente iremos garantir a conectividade entre os equipamentos, para isso iremos utilizar o GNS3.

Router

enable
configure terminal
!
hostname Router
!
interface f0/0
ip address 200.200.200.9 255.255.255.252
description WAN
no shut
exit
!
interface f0/1
ip address 192.168.1.1 255.255.255.0
description LAN
no shut
exit
!
end
wr

Uma vez com a conectividade entre os dispositivos OK, iremos partir para a configuração do DHCP.

configure terminal
!
ip dhcp pool LAN_192.168.1.0
network 192.168.1.0 255.255.255.0
dns-server 8.8.8.8
default-router 192.168.1.1
domain-name home.vsoc.com.br
lease 7 0 5 ! (lease infinite)
exit

Na opção lease definimos o tempo para que o cliente pegue um novo endereço IP do DHCP, no nosso exemplo ficou 7 dias 0 horas 5 minutos, porém seria possível deixar este endereço de forma permanente através da opção lease infinite.

Foi definido a rede 192.168.1.0/24 para ser distribuída no DHCP, porém é muito comum excluirmos alguns IPs do DHCP para ser utilizados em outros serviços.

configure terminal
ip dhcp excluded-address 192.168.1.1 192.168.1.10

Uma vez devidamente configurado, iremos habilitar o serviço DHCP.

service dhcp

Uma vez habilitado iremos verificar seu status.

Informações de clientes conectados.

show ip dhcp  binding

cisco_dhcp02

Estatísticas do  serviço DHCP

show ip dhcp  server statistics

cisco_dhcp03

Em casos de troubleshooting mais complexos, também é possível habilitar o debug.

debug ip dhcp server ?

cisco_dhcp04

Caso seja necessário limpar um host ou toda a tabela dos clientes conectados no DHCP, utilize o comando abaixo.

clear ip dhcp binding ?

cisco_dhcp05

Agora apenas para validarmos nossas configurações, vamos dar uma olhada no Host que está com o DHCP habilitado.

cisco_dhcp06

E assim finalizamos mais um post.

Tags: