Cisco: GLBP

Neste post vou demonstrar o funcionamento do protocolo GLBP (Gateway Load Balance Protocolo), que é utilizado para garantir o funcionamento da redundância entre roteadores e realizar a o balanceamento de carga entre gateways.

No GLBP é setado um endereço virtual, onde este endereço terá múltiplos MAC address dos roteadores participantes do grupo GLBP.

Assim como o HSRP e VRRP o roteador com maior prioridade se torna o ativo, porém no GLBP é dado o nome AVG (Active Virtual Router), onde sua responsabilidade será apenas de  responder os ARPs requests enviados a o endereço L3 do roteador virtual. O AVG encaminha o ARP replies com endereços L2 virtuais dos outros roteadores pertencentes no grupo GLBP. É dado o nome AVF (Active Virtual Forwardes) aos roteadores que encaminham tráfego por meio desse endereço L2 atribuído pelo AVG.

Por padrão o GLBP trabalha com o balanceamento round robin.

Iremos realizar um lab para demonstrar suas configurações e funcionamento, para isso faremos uso do GNS3.

Topologia utilizada:

cisco_glbp01

Primeiramente iremos garantir a conectividade entre os equipamentos.

RouterA

enable
configure terminal
!
hostname RouterA
!
interface f0/0
description WAN_Link1
ip address 200.200.200.9 255.255.255.252
no shut
exit
!
interface f0/1
description SWLan
ip address 192.168.1.2 255.255.255.0
no shut
exit
!
end
wr

RouterB

enable
configure terminal
!
hostname RouterB
!
interface f0/0
description WAN_Link2
ip address 100.100.100.9 255.255.255.252
no shut
exit
!
interface f0/1
description SWLan
ip address 192.168.1.3 255.255.255.0
no shut
exit
!
end
wr

O próximo passo é configurar o GLBP nos roteadores.

RouterA

interface f0/1
glbp 1 name GLBP_WANLink1
glbp 1 authentication text pw123!
glbp 1 ip 192.168.1.1
glbp 1 priority 120
glbp 1 preempt
exit
!
end
wr

RouterB

interface f0/1
glbp 1 name GLBP_WANLink2
glbp 1 authentication text pw123!
glbp 1 ip 192.168.1.1
glbp 1 priority 110
exit
!
end
wr

Agora iremos verificar o status do GLBP.

RouterA

show glbp

cisco_glbp02

RouterB

show glbp

cisco_glbp03

Para prosseguirmos com os próximos testes, iremos configurar o endereço nos hosts.

Host

cisco_glbp04

Host_2

cisco_glbp05

Para validarmos a contingencia entre os roteadores, deixarei os hosts pingando o endereço de Internet 100.100.100.10.

Porém para isso, será necessário aplicarmos um NAT.

RouterA

configure terminal
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
ip nat inside source list 1 interface f0/0 overload
!
interface f0/0
ip nat outside
exit
!
interface f0/1
ip nat inside
exit
!

RouterB

configure terminal
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
ip nat inside source list 1 interface f0/0 overload
!
interface f0/0
ip nat outside
exit
!
interface f0/1
ip nat inside
exit
!

Desta forma os endereços privados serão nateados por suas interfaces publicas.

Host

cisco_glbp06

RouterA

cisco_glbp07

Reparem que o tráfego para o endereçamento externo foi realizado pelo RouterA.

Host_2

cisco_glbp08

RouterB

cisco_glbp09

Reparem que agora o tráfego para o endereço externo foi realizado pelo RouterB

E assim finalizamos mais um post.

Tags: