Cisco: HSRP

Neste post vou demonstrar o funcionamento do protocolo Cisco Hot-Standby Routing Protocol (HSRP), que é utilizado para garantir o funcionamento da redundância entre roteadores. Por ser proprietário seu funcionamento se limita aos equipamentos Cisco.

Iremos realizar um lab para demonstrar suas configurações e funcionamento.

Topologia utilizada:

cisco_hsrp01

Primeiramente iremos garantir a conectividade entre os equipamentos, para isso iremos utilizar o GNS3.

cisco_hsrp02

RouterA

enable
configure terminal
hostname RouterA
!
interface f0/0
no shut
exit
!
interface f0/1
ip address 192.168.1.1 255.255.255.0
standby 1 name WAN_HSRP_1
standby 1 ip 192.168.1.3 !(endereco ip do vip)
standby 1 priority 120 !(default é 100)
standby 1 preempt
standby 1 track interface f0/0 20
no shutdown
exit
!
end
wr

No RouterA foi configurado uma track, onde caso ocorra um evento com a interface f0/0, que está ligada no provedor, sua prioridade terá um decréscimo de 20 ( 120 – 20 = 100), possuindo uma prioridade menor que do RouterB. Desta forma será realizado um chaveamento, onde o RouterB assumirá como o Active.

RouterB

enable
configure terminal
hostname RouterB
!
interface f0/0
no shut
exit
!
interface f0/1
ip address 192.168.1.2 255.255.255.0
standby 1 name WAN_HSRP_1
standby 1 ip 192.168.1.3 !(endereco ip do vip)
standby 1 priority 110 !(default é 100)
standby 1 preempt
no shutdown
!
end
wr

Após realizarmos as configurações, iremos verificar o status do HSRP nos roteadores.

RouterA

show standby

cisco_hsrp03

Como pode ser exibido, o RouterA está como Active no HSRP.

RouterB

cisco_hsrp04

Enquanto o RouterB está como Standby.

Agora a partir do nosso host, iremos gerar trafego para o IP do VIP.

cisco_hsrp05

Para testarmos o HSRP  irei realizar um shut na interface f0/0 do RouterA, que está ligada ao provedor, desta forma o RouterB terá que assumir como Active.

RouterA

cisco_hsrp06

RouterB

cisco_hsrp07

Host

cisco_hsrp08

Com o shut na interface f0/0, houve o decréscimo de 20 ( 120 – 20 = 100 ), fazendo com que o  a prioridade no RouterB ficasse maior, e se tornando o Active no HSRP.

Uma vez que a interface f0/0 volte a seu funcionamento o decréscimo é voltado a seu valor original, porém o chaveamento do RouterB para o RouterA deve ser manual.

E assim finalizamos mais um post.

Tags: