Cisco: Passwords

Neste post vou demonstrar as diferentes formas de configurar as credencias de acesso em dispositivos Cisco.

Topologia utilizada para demonstrar as configurações:

cisco_password01

Garantindo a conectividade entre os dispositivos.

RouterA

enable
configure terminal
!
hostname RouterA
!
interface f0/0
ip address 200.200.200.1 255.255.255.252
no shut
!
interface f0/1
ip address 172.16.0.1 255.255.255.0
no shut
!
end
wr

Host

ifconfig eth0 172.16.0.10 netmask 255.255.255.0
route add default gw 172.16.0.1

O primeiro modo de configurar a senha é através do comando abaixo:

configure terminal
enable password cisco

Após isso o acesso ao modo de configuração global ira requerer a senha setada.

Porém o enable password possui falhas de segurança, a primeira é no armazenamento em texto claro.

sh run | i enable

cisco_password02

Através do comando abaixo as senhas em texto claro são criptografadas.

configure terminal
service password-encryption

Reparem que a senha foi criptografada.

cisco_password03

Esta criptografia é proprietária ta Cisco, onde já possui mecanismos para converte-la para texto claro.

Este link realiza está função: http://www.ibeast.com/content/tools/CiscoPassword

Outro método de configurar a senha para o modo privilegiado e ao modo global, porém de forma segura é através do secret.

configure terminal
enable secret cisco123

Reparem que a senha é criptografada e com um algoritmo mais forte.

cisco_password04

O próximo passo é configurar o Router para permitir o acesso remoto.

configure terminal
line vty 0 4
password 123mudar
login

Reparem no sh run que a senha setada no password também está em texto claro, isso pois foi desabilitado a opção password-encryption.

cisco_password05

Realizando o acesso ao RouterA através do Host

cisco_password06

(1) senha do vty

(2) senha do secret (caso existe a configuração do enable password e secret no mesmo dispositivo, a secret será a valida)

O próximo passo será criar usuários locais no RouterA para ser utilizamos no acesso através do vty.

configure terminal
username vinicius secret 123
username bueno password 456

Reparem que foi criado dois usuários, um fazendo uso do secret e outro do password.

cisco_password07

Agora iremos ajustar o vty.

configure terminal
line vty 0 4
no password
login local

cisco_password08

Agora através do Host iremos conectar ao dispositivo com os usuários.

cisco_password09

E assim finalizamos mais um post.

Tags: