Cisco: VRRP

Neste post vou demonstrar o funcionamento do protocolo VRRP (Virtual Routing Redundancy Protocol), que é utilizado para garantir o funcionamento da redundância entre roteadores. Mantido pelo IETF, este protocolo roda em equipamentos que suporta a RFC 3768.

Iremos realizar um lab para demonstrar suas configurações e funcionamento.

Topologia utilizada:

cisco_vrrp_0

Primeiramente iremos garantir a conectividade entre os equipamentos, para isso iremos utilizar o GNS3.

cisco_vrrp_02

 

RouterA

enable
configure terminal
hostname RouterA
!
interface f0/0
no shut
exit
!
interface f0/1
ip address 192.168.1.1 255.255.255.0
vrrp 1 description WAN_VRRP_1
vrrp 1 ip 192.168.1.1 !(endereco ip do vip)
vrrp 1 preempt
no shutdown
exit
!
end
wr

RouterB

enable
configure terminal
hostname RouterB
!
interface f0/0
no shut
exit
!
interface f0/1
ip address 192.168.1.2 255.255.255.0
vrrp 1 description WAN_VRRP_1
vrrp 1 ip 192.168.1.1 ! (endereco ip do vip)
vrrp 1 priority 110 ! (default é 100)
vrrp 1 preempt
no shutdown
!
end
wr

Após realizarmos as configurações, iremos verificar o status do VRRP nos roteadores.

RouterA

show vrrp

cisco_vrrp_03

Como pode ser exibido, o RouterA está como Master no VRRP.

Router B

cisco_vrrp_04

Enquanto o RouterB está como Backup.

Agora a partir do nosso host, iremos gerar trafego para o IP configurado no VRRP.

cisco_vrrp_06

Para testarmos o VRRP irei realizar um shut na interface f0/1 do RouterA, testar formar o RouterB terá que assumir como Master.

RouterA

cisco_vrrp_07

RouterB

cisco_vrrp_08

Host

cisco_vrrp_09

Com o shut o RouterB assumiu como Master, onde o Host continuou pingando o endereço do VIP 192.168.1.1.

Ao voltar a interface do RouterA para ativa, automaticamente o RouterB volta a ser Backup.

RouterA

cisco_vrrp_10

E assim finalizamos mais um post.

Tags: